{"answers":{"affected":"15 open source packages ship an affected version, including recurly. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-0906 in the wild and no public exploit code.","fix":"Upgrade recurly to a fixed version for your release line: 2.0.5, 2.1.16, 2.2.22 or 2.3.1.","what":"CVE-2017-0906 is a critical server-side request forgery vulnerability in recurly python module, published on 13 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-0906 and fix it if it is affected.\n\nWhat it is: CVE-2017-0906 is a critical server-side request forgery vulnerability in recurly python module, published on 13 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-0906 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- recurly (PyPI): affected all versions; fixed in 2.0.5\n- recurly (PyPI): affected all versions; fixed in 2.0.5\n- recurly (PyPI): affected from 2.0; fixed in 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2\n- recurly (PyPI): affected from 2.1.0; fixed in 2.1.16\n- recurly (PyPI): affected from 2.1.0; fixed in 2.1.16\n- recurly (PyPI): affected from 2.2.0; fixed in 2.2.22\n- recurly (PyPI): affected from 2.2.0; fixed in 2.2.22\n- recurly (PyPI): affected from 2.3.0; fixed in 2.3.1\n- recurly (PyPI): affected from 2.3.0; fixed in 2.3.1\n- recurly (PyPI): affected from 2.4.0; fixed in 2.4.5\n- recurly (PyPI): affected from 2.4.0; fixed in 2.4.5\n- recurly (PyPI): affected from 2.5.0; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-0906/ (Markdown: https://insights.sbomify.com/CVE-2017-0906/index.md)","id":"CVE-2017-0906","markdown":"https://insights.sbomify.com/CVE-2017-0906/index.md","name":"CVE-2017-0906","record":{"aliases":["GHSA-38rv-5jqc-m2cv","PYSEC-2017-68"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Recurly Python library","requires_auth":"none","summary":"An SSRF vulnerability in the Recurly Python library allows attackers to compromise API keys and access critical resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"recurly_client_python","vendor":"recurly"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the \"Resource.get\" method that could result in compromise of API keys or other critical resources.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Recurly vulnerable to SSRF","id":"CVE-2017-0906","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2017"},"n_packages":15,"n_references":3,"next":{"headline":"Critical severity vulnerability that affects recurly-api-client","id":"CVE-2017-0907"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"recurly","purl":null,"source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.0.5","2.1.16","2.2.22","2.3.1","2.4.5","2.5.1","2.6.2"],"introduced":["2.0","2.1","2.2","2.3","2.4","2.5","2.6"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"PYSEC-2017-68"},{"ecosystem":"PyPI","fixed":["2.1.16"],"introduced":["2.1.0"],"last_affected":[],"package":"recurly","purl":null,"source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.1.16"],"introduced":["2.1.0"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.2.22"],"introduced":["2.2.0"],"last_affected":[],"package":"recurly","purl":null,"source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.2.22"],"introduced":["2.2.0"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.3.1"],"introduced":["2.3.0"],"last_affected":[],"package":"recurly","purl":null,"source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.3.1"],"introduced":["2.3.0"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.4.5"],"introduced":["2.4.0"],"last_affected":[],"package":"recurly","purl":null,"source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.4.5"],"introduced":["2.4.0"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["2.5.0"],"last_affected":[],"package":"recurly","purl":null,"source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["2.5.0"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.6.2"],"introduced":["2.6.0"],"last_affected":[],"package":"recurly","purl":null,"source":"GHSA-38rv-5jqc-m2cv"},{"ecosystem":"PyPI","fixed":["2.6.2"],"introduced":["2.6.0"],"last_affected":[],"package":"recurly","purl":"pkg:pypi/recurly","source":"GHSA-38rv-5jqc-m2cv"}],"prev":{"headline":"Recurly gem Server-Side Request Forgery in Resource#find method","id":"CVE-2017-0905"},"products":["recurly python module"],"published":"2017-11-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Recurly"]},"summary":"An SSRF vulnerability in the Recurly Python library allows attackers to compromise API keys and access critical resources.","url":"https://insights.sbomify.com/CVE-2017-0906/"}