{"answers":{"affected":"3 open source packages ship an affected version, including fedmsg and FedMsg. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000001 in the wild and no public exploit code.","fix":"Upgrade fedmsg to 0.18.2 or later.","what":"CVE-2017-1000001 is a high-severity vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000001 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000001 is a high-severity vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000001 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fedmsg (PyPI): affected all versions; fixed in 0.18.2\n- fedmsg (PyPI): affected all versions; fixed in 0.18.2\n- FedMsg (PyPI): affected all versions; fixed in 0.18.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000001/ (Markdown: https://insights.sbomify.com/CVE-2017-1000001/index.md)","id":"CVE-2017-1000001","markdown":"https://insights.sbomify.com/CVE-2017-1000001/index.md","name":"CVE-2017-1000001","record":{"aliases":["GHSA-p7xc-35m8-57pr","PYSEC-2017-13","UBUNTU-CVE-2017-1000001"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"FedMsg messaging library","requires_auth":"none","summary":"Attackers can bypass message validation in FedMsg if it is explicitly configured to be enabled, potentially allowing malicious messages to be processed.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedmsg","vendor":"fedoraproject"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FedMsg not properly completing message validation","id":"CVE-2017-1000001","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2017-1000002"},"packages":[{"ecosystem":"PyPI","fixed":["0.18.2"],"introduced":["0"],"last_affected":[],"package":"FedMsg","purl":null,"source":"GHSA-p7xc-35m8-57pr"},{"ecosystem":"PyPI","fixed":["0.18.2"],"introduced":["0"],"last_affected":[],"package":"fedmsg","purl":"pkg:pypi/fedmsg","source":"GHSA-p7xc-35m8-57pr"},{"ecosystem":"PyPI","fixed":["0.18.2"],"introduced":["0"],"last_affected":[],"package":"fedmsg","purl":"pkg:pypi/fedmsg","source":"PYSEC-2017-13"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-1000000"},"products":["n/a"],"published":"2017-07-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass message validation in FedMsg if it is explicitly configured to be enabled, potentially allowing malicious messages to be processed.","url":"https://insights.sbomify.com/CVE-2017-1000001/"}