{"answers":{"affected":"2 open source packages ship an affected version, including plotly.js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000006 in the wild and no public exploit code.","fix":"Upgrade plotly.js to 1.16.0 or later.","what":"CVE-2017-1000006 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000006 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000006 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000006 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plotly.js (npm): affected all versions; fixed in 1.16.0\n- plotly.js (npm): affected all versions; fixed in 1.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000006/ (Markdown: https://insights.sbomify.com/CVE-2017-1000006/index.md)","id":"CVE-2017-1000006","markdown":"https://insights.sbomify.com/CVE-2017-1000006/index.md","name":"CVE-2017-1000006","record":{"aliases":["GHSA-2fqv-h3r5-m4vf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript plotting library","requires_auth":"none","summary":"An XSS vulnerability in plotly.js allows attackers to execute arbitrary scripts in the context of the user's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"plotly.js","vendor":"plotly"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross Site Scripting (XSS) in plotly.js","id":"CVE-2017-1000006","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"txAWS AWSServiceEndpoint defaults to not verifying server certificates","id":"CVE-2017-1000007"},"packages":[{"ecosystem":"npm","fixed":["1.16.0"],"introduced":["0"],"last_affected":[],"package":"plotly.js","purl":null,"source":"GHSA-2fqv-h3r5-m4vf"},{"ecosystem":"npm","fixed":["1.16.0"],"introduced":["0"],"last_affected":[],"package":"plotly.js","purl":"pkg:npm/plotly.js","source":"GHSA-2fqv-h3r5-m4vf"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000005"},"products":["n/a"],"published":"2017-07-13","related":[{"cvss_score":9.8,"headline":"plotly.js prototype pollution vulnerability","id":"CVE-2023-46308","kev_date_added":null,"published":"2024-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An XSS vulnerability in plotly.js allows attackers to execute arbitrary scripts in the context of the user's browser.","url":"https://insights.sbomify.com/CVE-2017-1000006/"}