# CVE-2017-1000006: Cross Site Scripting (XSS) in plotly.js

> An XSS vulnerability in plotly.js allows attackers to execute arbitrary scripts in the context of the user's browser.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2fqv-h3r5-m4vf

## What is CVE-2017-1000006?

CVE-2017-1000006 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000006?

2 open source packages ship an affected version, including plotly.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plotly.js` | npm | All versions | 1.16.0 |
| `plotly.js` | npm | All versions | 1.16.0 |

Products: Plotly Plotly.js.

## How do I fix CVE-2017-1000006?

Upgrade plotly.js to 1.16.0 or later.

## Is CVE-2017-1000006 being exploited?

There is no known exploitation of CVE-2017-1000006 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-46308](https://insights.sbomify.com/CVE-2023-46308/): plotly.js prototype pollution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000006 and fix it if it is affected.

What it is: CVE-2017-1000006 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000006 in the wild and no public exploit code.

Affected packages and fixed versions:
- plotly.js (npm): affected all versions; fixed in 1.16.0
- plotly.js (npm): affected all versions; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000006/ (Markdown: https://insights.sbomify.com/CVE-2017-1000006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000006
- OSV: https://osv.dev/vulnerability/CVE-2017-1000006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000006/
Summaries are generated and may contain mistakes; the official description above is the record.
