# CVE-2017-1000034: Akka Java Serialization vulnerability

> Remote attackers can execute arbitrary code via unsafe Java deserialization in the Akka Remoting component.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mm57-9j6q-rxm2

## What is CVE-2017-1000034?

CVE-2017-1000034 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Akka versions <=2.4.16 and 2.5-M1 are vulnerable to a java deserialization attack in its Remoting component resulting in remote code execution in the context of the ActorSystem.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-1000034?

2 open source packages ship an affected version, including com.typesafe.akka:akka-actor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.typesafe.akka:akka-actor` | Maven | All versions | 2.4.17 |
| `com.typesafe.akka:akka-actor` | Maven | All versions | 2.4.17 |

Products: Akka Akka.

## How do I fix CVE-2017-1000034?

Upgrade com.typesafe.akka:akka-actor to 2.4.17 or later.

## Is CVE-2017-1000034 being exploited?

There is no known exploitation of CVE-2017-1000034 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000034 and fix it if it is affected.

What it is: CVE-2017-1000034 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000034 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.typesafe.akka:akka-actor (Maven): affected all versions; fixed in 2.4.17
- com.typesafe.akka:akka-actor (Maven): affected all versions; fixed in 2.4.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000034/ (Markdown: https://insights.sbomify.com/CVE-2017-1000034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000034
- OSV: https://osv.dev/vulnerability/CVE-2017-1000034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000034/
Summaries are generated and may contain mistakes; the official description above is the record.
