CVE-2017-1000048 Prototype Pollution Protection Bypass in qs
A malicious user can crash the web framework by sending a crafted request to the vulnerable qs module, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-1000048?
CVE-2017-1000048 is a high-severity denial of service vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS. A malicious user can send a evil request to cause the web framework crash.
Weakness: CWE-20
Which versions are affected by CVE-2017-1000048?
8 open source packages ship an affected version, including qs. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
qs npm | All versions | 6.0.4 |
qs npm | All versions | 6.0.4 |
qs npm | From 6.1.0 | 6.1.2 |
qs npm | From 6.1.0 | 6.1.2 |
qs npm | From 6.2.0 | 6.2.3 |
qs npm | From 6.2.0 | 6.2.3 |
2 more packages
qs npm | From 6.3.0 | 6.3.2 |
qs npm | From 6.3.0 | 6.3.2 |
Linux distribution packages (2)
rh-nodejs6-nodejs-qs Red Hat:rhel_software_collections:2::el6 | All versions | 0:6.2.3-1.el6 |
rh-nodejs6-nodejs-qs Red Hat:rhel_software_collections:2::el7 | All versions | 0:6.2.3-1.el7 |
Products include Qs Project Qs.
How do I fix CVE-2017-1000048?
Upgrade qs to a fixed version for your release line: 6.0.4, 6.1.2, 6.2.3 or 6.3.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-1000048 being exploited?
There is no known exploitation of CVE-2017-1000048 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as AZL-45075, CLSA-2026-1773188136, CLSA-2026-1784509812, CLSA-2026-1784596277, GHSA-gqgv-6jq5-jjj9, RHSA-2017:2672 and 1 more.