{"answers":{"affected":"8 open source packages ship an affected version, including qs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000048 in the wild and no public exploit code.","fix":"Upgrade qs to a fixed version for your release line: 6.0.4, 6.1.2, 6.2.3 or 6.3.2.","what":"CVE-2017-1000048 is a high-severity denial of service vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000048 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000048 is a high-severity denial of service vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000048 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- qs (npm): affected all versions; fixed in 6.0.4\n- qs (npm): affected all versions; fixed in 6.0.4\n- qs (npm): affected from 6.1.0; fixed in 6.1.2\n- qs (npm): affected from 6.1.0; fixed in 6.1.2\n- qs (npm): affected from 6.2.0; fixed in 6.2.3\n- qs (npm): affected from 6.2.0; fixed in 6.2.3\n- qs (npm): affected from 6.3.0; fixed in 6.3.2\n- qs (npm): affected from 6.3.0; fixed in 6.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000048/ (Markdown: https://insights.sbomify.com/CVE-2017-1000048/index.md)","id":"CVE-2017-1000048","markdown":"https://insights.sbomify.com/CVE-2017-1000048/index.md","name":"CVE-2017-1000048","record":{"aliases":["AZL-45075","CLSA-2026-1773188136","CLSA-2026-1784509812","CLSA-2026-1784596277","GHSA-gqgv-6jq5-jjj9","RHSA-2017:2672","ROOT-APP-NPM-CVE-2017-1000048"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js query string parser","requires_auth":"none","summary":"A malicious user can crash the web framework by sending a crafted request to the vulnerable qs module, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"qs","vendor":"qs_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS. A malicious user can send a evil request to cause the web framework crash.","ecosystems":["Red Hat:rhel_software_collections:2::el6","Red Hat:rhel_software_collections:2::el7","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prototype Pollution Protection Bypass in qs","id":"CVE-2017-1000048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":10,"n_references":2,"next":{"headline":"Null dereference in n/a","id":"CVE-2017-1000050"},"packages":[{"ecosystem":"npm","fixed":["6.0.4"],"introduced":["0"],"last_affected":[],"package":"qs","purl":null,"source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"npm","fixed":["6.0.4"],"introduced":["0"],"last_affected":[],"package":"qs","purl":"pkg:npm/qs","source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"npm","fixed":["6.1.2"],"introduced":["6.1.0"],"last_affected":[],"package":"qs","purl":null,"source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"npm","fixed":["6.1.2"],"introduced":["6.1.0"],"last_affected":[],"package":"qs","purl":"pkg:npm/qs","source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"npm","fixed":["6.2.3"],"introduced":["6.2.0"],"last_affected":[],"package":"qs","purl":null,"source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"npm","fixed":["6.2.3"],"introduced":["6.2.0"],"last_affected":[],"package":"qs","purl":"pkg:npm/qs","source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"npm","fixed":["6.3.2"],"introduced":["6.3.0"],"last_affected":[],"package":"qs","purl":null,"source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"npm","fixed":["6.3.2"],"introduced":["6.3.0"],"last_affected":[],"package":"qs","purl":"pkg:npm/qs","source":"GHSA-gqgv-6jq5-jjj9"},{"ecosystem":"Red Hat:rhel_software_collections:2::el6","fixed":["0:6.2.3-1.el6"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-qs","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-qs","source":"RHSA-2017:2672"},{"ecosystem":"Red Hat:rhel_software_collections:2::el7","fixed":["0:6.2.3-1.el7"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-qs","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-qs","source":"RHSA-2017:2672"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2017-1000047"},"products":["n/a"],"published":"2017-07-13","related":[{"cvss_score":7.5,"headline":"Denial-of-Service Extended Event Loop Blocking in qs","id":"CVE-2014-10064","kev_date_added":null,"published":"2018-05-31"},{"cvss_score":6.3,"headline":"qs's arrayLimit bypass in comma parsing allows denial of service","id":"CVE-2026-2391","kev_date_added":null,"published":"2026-02-12"},{"cvss_score":6.3,"headline":"arrayLimit bypass in bracket notation allows DoS via memory exhaustion","id":"CVE-2025-15284","kev_date_added":null,"published":"2025-12-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A malicious user can crash the web framework by sending a crafted request to the vulnerable qs module, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2017-1000048/"}