CVE-2017-1000053 Arbitrary Code Execution in Cookie Serialization
Attackers can execute arbitrary code via unsafe deserialization in Elixir Plug Session functions, requiring library upgrades.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-1000053?
CVE-2017-1000053 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to arbitrary code execution in the deserialization functions of Plug.Session.
Weakness: CWE-502
Which versions are affected by CVE-2017-1000053?
8 open source packages ship an affected version, including plug. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plug Hex | All versions | 1.0.4 |
plug Hex | All versions | 1.0.4 |
plug Hex | From 1.1.0 | 1.1.7 |
plug Hex | From 1.1.0 | 1.1.7 |
plug Hex | From 1.2.0 | 1.2.3 |
plug Hex | From 1.2.0 | 1.2.3 |
2 more packages
plug Hex | From 1.3.0 | 1.3.2 |
plug Hex | From 1.3.0 | 1.3.2 |
Products include Plug Project Plug.
How do I fix CVE-2017-1000053?
Upgrade plug to a fixed version for your release line: 1.0.4, 1.1.7, 1.2.3 or 1.3.2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2017-1000053 being exploited?
There is no known exploitation of CVE-2017-1000053 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-5v4m-c73v-c7gq.