{"answers":{"affected":"8 open source packages ship an affected version, including plug. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000053 in the wild and no public exploit code.","fix":"Upgrade plug to a fixed version for your release line: 1.0.4, 1.1.7, 1.2.3 or 1.3.2.","what":"CVE-2017-1000053 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000053 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000053 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000053 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plug (Hex): affected all versions; fixed in 1.0.4\n- plug (Hex): affected all versions; fixed in 1.0.4\n- plug (Hex): affected from 1.1.0; fixed in 1.1.7\n- plug (Hex): affected from 1.1.0; fixed in 1.1.7\n- plug (Hex): affected from 1.2.0; fixed in 1.2.3\n- plug (Hex): affected from 1.2.0; fixed in 1.2.3\n- plug (Hex): affected from 1.3.0; fixed in 1.3.2\n- plug (Hex): affected from 1.3.0; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000053/ (Markdown: https://insights.sbomify.com/CVE-2017-1000053/index.md)","id":"CVE-2017-1000053","markdown":"https://insights.sbomify.com/CVE-2017-1000053/index.md","name":"CVE-2017-1000053","record":{"aliases":["GHSA-5v4m-c73v-c7gq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir Plug library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsafe deserialization in Elixir Plug Session functions, requiring library upgrades.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"plug","vendor":"plug_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to arbitrary code execution in the deserialization functions of Plug.Session.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary Code Execution in Cookie Serialization","id":"CVE-2017-1000053","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"deserialization","year":"2017"},"n_packages":8,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000054"},"packages":[{"ecosystem":"Hex","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-5v4m-c73v-c7gq"},{"ecosystem":"Hex","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-5v4m-c73v-c7gq"},{"ecosystem":"Hex","fixed":["1.1.7"],"introduced":["1.1.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-5v4m-c73v-c7gq"},{"ecosystem":"Hex","fixed":["1.1.7"],"introduced":["1.1.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-5v4m-c73v-c7gq"},{"ecosystem":"Hex","fixed":["1.2.3"],"introduced":["1.2.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-5v4m-c73v-c7gq"},{"ecosystem":"Hex","fixed":["1.2.3"],"introduced":["1.2.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-5v4m-c73v-c7gq"},{"ecosystem":"Hex","fixed":["1.3.2"],"introduced":["1.3.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-5v4m-c73v-c7gq"},{"ecosystem":"Hex","fixed":["1.3.2"],"introduced":["1.3.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-5v4m-c73v-c7gq"}],"prev":{"headline":"Null Byte Injection in Plug.Static","id":"CVE-2017-1000052"},"products":["n/a"],"published":"2017-07-13","related":[{"cvss_score":7.8,"headline":"Null Byte Injection in Plug.Static","id":"CVE-2017-1000052","kev_date_added":null,"published":"2017-07-13"},{"cvss_score":6.5,"headline":"Header Injection","id":"CVE-2018-1000883","kev_date_added":null,"published":"2018-12-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via unsafe deserialization in Elixir Plug Session functions, requiring library upgrades.","url":"https://insights.sbomify.com/CVE-2017-1000053/"}