CVE-2017-1000056 Kubernetes Privilege Escalation

Critical 9.8 Published Updated

Attackers can escalate privileges by exploiting a flaw in the PodSecurityPolicy admission plugin to use any existing policy object.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000056?

CVE-2017-1000056 is a critical vulnerability in Kubernetes Kubernetes, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Weakness: CWE-862

Which versions are affected by CVE-2017-1000056?

3 open source packages ship an affected version, including k8s.io/kubernetes. It affects 1 product.

PackageAffectedFixed in
k8s.io/kubernetes GoFrom 1.5.01.5.5
k8s.io/kubernetes GoFrom 1.5.01.5.5
k8s.io/kubernetes GoFrom 1.5.01.5.5

Products include Kubernetes Kubernetes.

How do I fix CVE-2017-1000056?

Upgrade k8s.io/kubernetes to 1.5.5 or later.

Is CVE-2017-1000056 being exploited?

There is no known exploitation of CVE-2017-1000056 in the wild and no public exploit code.

All Kubernetes Kubernetes vulnerabilities

Sources

Also known as DEBIAN-CVE-2017-1000056, GHSA-2jx2-76rc-2v7v, GO-2023-1492.

Is CVE-2017-1000056 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free