{"answers":{"affected":"3 open source packages ship an affected version, including k8s.io/kubernetes. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000056 in the wild and no public exploit code.","fix":"Upgrade k8s.io/kubernetes to 1.5.5 or later.","what":"CVE-2017-1000056 is a critical vulnerability in Kubernetes Kubernetes, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000056 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000056 is a critical vulnerability in Kubernetes Kubernetes, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000056 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- k8s.io/kubernetes (Go): affected from 1.5.0; fixed in 1.5.5\n- k8s.io/kubernetes (Go): affected from 1.5.0; fixed in 1.5.5\n- k8s.io/kubernetes (Go): affected from 1.5.0; fixed in 1.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000056/ (Markdown: https://insights.sbomify.com/CVE-2017-1000056/index.md)","id":"CVE-2017-1000056","markdown":"https://insights.sbomify.com/CVE-2017-1000056/index.md","name":"CVE-2017-1000056","record":{"aliases":["DEBIAN-CVE-2017-1000056","GHSA-2jx2-76rc-2v7v","GO-2023-1492"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Kubernetes cluster","requires_auth":"none","summary":"Attackers can escalate privileges by exploiting a flaw in the PodSecurityPolicy admission plugin to use any existing policy object.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"kubernetes","vendor":"kubernetes"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kubernetes Privilege Escalation","id":"CVE-2017-1000056","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"kubernetes:kubernetes","products":["kubernetes:kubernetes"],"type":"privilege_escalation","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-1000057"},"packages":[{"ecosystem":"Go","fixed":["1.5.5"],"introduced":["1.5.0"],"last_affected":[],"package":"k8s.io/kubernetes","purl":null,"source":"GHSA-2jx2-76rc-2v7v"},{"ecosystem":"Go","fixed":["1.5.5"],"introduced":["1.5.0"],"last_affected":[],"package":"k8s.io/kubernetes","purl":"pkg:golang/k8s.io/kubernetes","source":"GHSA-2jx2-76rc-2v7v"},{"ecosystem":"Go","fixed":["1.5.5"],"introduced":["1.5.0"],"last_affected":[],"package":"k8s.io/kubernetes","purl":"pkg:golang/k8s.io/kubernetes","source":"GO-2023-1492"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-1000055"},"products":["n/a"],"published":"2017-07-13","related":[{"cvss_score":9.8,"headline":"Privilege Escalation in Kubernetes","id":"CVE-2018-1002105","kev_date_added":null,"published":"2018-12-05"},{"cvss_score":9.8,"headline":"Authorization bypass in Openshift","id":"CVE-2016-1906","kev_date_added":null,"published":"2016-02-03"},{"cvss_score":8.8,"headline":"Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation","id":"CVE-2023-3676","kev_date_added":null,"published":"2023-10-31"},{"cvss_score":8.8,"headline":"Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation","id":"CVE-2023-3955","kev_date_added":null,"published":"2023-10-31"},{"cvss_score":8.8,"headline":"Symlink Exchange Can Allow Host Filesystem Access","id":"CVE-2021-25741","kev_date_added":null,"published":"2021-09-20"},{"cvss_score":8.8,"headline":"Path traversal in Kubernetes","id":"CVE-2017-1002101","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can escalate privileges by exploiting a flaw in the PodSecurityPolicy admission plugin to use any existing policy object.","url":"https://insights.sbomify.com/CVE-2017-1000056/"}