# CVE-2017-1000056: Kubernetes Privilege Escalation

> Attackers can escalate privileges by exploiting a flaw in the PodSecurityPolicy admission plugin to use any existing policy object.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1000056, GHSA-2jx2-76rc-2v7v, GO-2023-1492

## What is CVE-2017-1000056?

CVE-2017-1000056 is a critical vulnerability in Kubernetes Kubernetes, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2017-1000056?

3 open source packages ship an affected version, including k8s.io/kubernetes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/kubernetes` | Go | From 1.5.0 | 1.5.5 |
| `k8s.io/kubernetes` | Go | From 1.5.0 | 1.5.5 |
| `k8s.io/kubernetes` | Go | From 1.5.0 | 1.5.5 |

Products: Kubernetes Kubernetes.

## How do I fix CVE-2017-1000056?

Upgrade k8s.io/kubernetes to 1.5.5 or later.

## Is CVE-2017-1000056 being exploited?

There is no known exploitation of CVE-2017-1000056 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2016-1906](https://insights.sbomify.com/CVE-2016-1906/): Authorization bypass in Openshift (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2021-25741](https://insights.sbomify.com/CVE-2021-25741/): Symlink Exchange Can Allow Host Filesystem Access (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000056 and fix it if it is affected.

What it is: CVE-2017-1000056 is a critical vulnerability in Kubernetes Kubernetes, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000056 in the wild and no public exploit code.

Affected packages and fixed versions:
- k8s.io/kubernetes (Go): affected from 1.5.0; fixed in 1.5.5
- k8s.io/kubernetes (Go): affected from 1.5.0; fixed in 1.5.5
- k8s.io/kubernetes (Go): affected from 1.5.0; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000056/ (Markdown: https://insights.sbomify.com/CVE-2017-1000056/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000056
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000056
- OSV: https://osv.dev/vulnerability/CVE-2017-1000056

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000056/
Summaries are generated and may contain mistakes; the official description above is the record.
