CVE-2017-1000067 MODX Revolution blind SQL injection
Authenticated users can exploit blind SQL injection in MODX Revolution to access database contents and potentially escalate privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-1000067?
CVE-2017-1000067 is a high-severity SQL injection vulnerability in n/a, published on 13 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in authenticated user accessing database and possibly escalating privileges.
Weakness: CWE-89
Which versions are affected by CVE-2017-1000067?
2 open source packages ship an affected version, including modx/revolution. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
modx/revolution Packagist | From 2.0.0 | 2.6.0 |
modx/revolution Packagist | From 2.0.0 | 2.6.0 |
Products include Modx Revolution.
How do I fix CVE-2017-1000067?
Upgrade modx/revolution to 2.6.0 or later.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2017-1000067 being exploited?
There is no known exploitation of CVE-2017-1000067 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-phhm-6pgm-mxw9.