{"answers":{"affected":"2 open source packages ship an affected version, including modx/revolution. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000067 in the wild and no public exploit code.","fix":"Upgrade modx/revolution to 2.6.0 or later.","what":"CVE-2017-1000067 is a high-severity SQL injection vulnerability in n/a, published on 13 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000067 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000067 is a high-severity SQL injection vulnerability in n/a, published on 13 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000067 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modx/revolution (Packagist): affected from 2.0.0; fixed in 2.6.0\n- modx/revolution (Packagist): affected from 2.0.0; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000067/ (Markdown: https://insights.sbomify.com/CVE-2017-1000067/index.md)","id":"CVE-2017-1000067","markdown":"https://insights.sbomify.com/CVE-2017-1000067/index.md","name":"CVE-2017-1000067","record":{"aliases":["GHSA-phhm-6pgm-mxw9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"MODX CMS","requires_auth":"low_privilege","summary":"Authenticated users can exploit blind SQL injection in MODX Revolution to access database contents and potentially escalate privileges.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"revolution","vendor":"modx"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in authenticated user accessing database and possibly escalating privileges.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MODX Revolution blind SQL injection","id":"CVE-2017-1000067","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Auth bypass in n/a","id":"CVE-2017-1000068"},"packages":[{"ecosystem":"Packagist","fixed":["2.6.0"],"introduced":["2.0.0"],"last_affected":[],"package":"modx/revolution","purl":null,"source":"GHSA-phhm-6pgm-mxw9"},{"ecosystem":"Packagist","fixed":["2.6.0"],"introduced":["2.0.0"],"last_affected":[],"package":"modx/revolution","purl":"pkg:composer/modx/revolution","source":"GHSA-phhm-6pgm-mxw9"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2017-1000066"},"products":["n/a"],"published":"2017-07-13","related":[{"cvss_score":7.2,"headline":"Unrestricted Upload of File with Dangerous Type in MODX Revolution","id":"CVE-2022-26149","kev_date_added":null,"published":"2022-02-26"},{"cvss_score":2.6,"headline":"Cross-site scripting in n/a","id":"CVE-2010-4883","kev_date_added":null,"published":"2011-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated users can exploit blind SQL injection in MODX Revolution to access database contents and potentially escalate privileges.","url":"https://insights.sbomify.com/CVE-2017-1000067/"}