# CVE-2017-1000067: MODX Revolution blind SQL injection

> Authenticated users can exploit blind SQL injection in MODX Revolution to access database contents and potentially escalate privileges.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-phhm-6pgm-mxw9

## What is CVE-2017-1000067?

CVE-2017-1000067 is a high-severity SQL injection vulnerability in n/a, published on 13 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in authenticated user accessing database and possibly escalating privileges.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-1000067?

2 open source packages ship an affected version, including modx/revolution. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modx/revolution` | Packagist | From 2.0.0 | 2.6.0 |
| `modx/revolution` | Packagist | From 2.0.0 | 2.6.0 |

Products: Modx Revolution.

## How do I fix CVE-2017-1000067?

Upgrade modx/revolution to 2.6.0 or later.

## Is CVE-2017-1000067 being exploited?

There is no known exploitation of CVE-2017-1000067 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26149](https://insights.sbomify.com/CVE-2022-26149/): Unrestricted Upload of File with Dangerous Type in MODX Revolution (high 7.2)
- [CVE-2010-4883](https://insights.sbomify.com/CVE-2010-4883/): Cross-site scripting in n/a (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000067 and fix it if it is affected.

What it is: CVE-2017-1000067 is a high-severity SQL injection vulnerability in n/a, published on 13 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000067 in the wild and no public exploit code.

Affected packages and fixed versions:
- modx/revolution (Packagist): affected from 2.0.0; fixed in 2.6.0
- modx/revolution (Packagist): affected from 2.0.0; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000067/ (Markdown: https://insights.sbomify.com/CVE-2017-1000067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000067
- OSV: https://osv.dev/vulnerability/CVE-2017-1000067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000067/
Summaries are generated and may contain mistakes; the official description above is the record.
