# CVE-2017-1000070: Open Redirect in oauth2_proxy

> An open redirect in the OAuth2 flow allows attackers to redirect users to malicious sites, potentially facilitating phishing or token theft.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jm34-xm8m-w958

## What is CVE-2017-1000070?

CVE-2017-1000070 is a medium-severity vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Bitly oauth2_proxy in version 2.1 and earlier was affected by an open redirect vulnerability during the start and termination of the 2-legged OAuth flow. This issue was caused by improper input validation and a violation of RFC-6819

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2017-1000070?

2 open source packages ship an affected version, including github.com/bitly/oauth2_proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/bitly/oauth2_proxy` | Go | All versions | 2.2.0 |
| `github.com/bitly/oauth2_proxy` | Go | All versions | 2.2.0 |

Products: Oauth2 Proxy Project Oauth2 Proxy.

## How do I fix CVE-2017-1000070?

Upgrade github.com/bitly/oauth2_proxy to 2.2.0 or later.

## Is CVE-2017-1000070 being exploited?

There is no known exploitation of CVE-2017-1000070 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-40575](https://insights.sbomify.com/CVE-2026-40575/): OAuth2 Proxy has an Authentication Bypass via X-Forwarded-Uri Header Spoofing (critical 9.1)
- [CVE-2026-34457](https://insights.sbomify.com/CVE-2026-34457/): OAuth2 Proxy: Health Check User-Agent Matching Bypasses Authentication in auth_request Mode (critical 9.1)
- [CVE-2025-54576](https://insights.sbomify.com/CVE-2025-54576/): OAuth2-Proxy has authentication bypass in oauth2-proxy skip_auth_routes due to Query Parameter inclusion (critical 9.1)
- [CVE-2017-1000069](https://insights.sbomify.com/CVE-2017-1000069/): Cross-site Request Forgery (CSRF) (high 8.8)
- [CVE-2026-41059](https://insights.sbomify.com/CVE-2026-41059/): OAuth2 Proxy has an Authentication Bypass via Fragment Confusion in skip_auth_routes and skip_auth_regex (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000070 and fix it if it is affected.

What it is: CVE-2017-1000070 is a medium-severity vulnerability in n/a, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000070 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/bitly/oauth2_proxy (Go): affected all versions; fixed in 2.2.0
- github.com/bitly/oauth2_proxy (Go): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000070/ (Markdown: https://insights.sbomify.com/CVE-2017-1000070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000070
- OSV: https://osv.dev/vulnerability/CVE-2017-1000070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000070/
Summaries are generated and may contain mistakes; the official description above is the record.
