# CVE-2017-1000084: Parameterized Trigger Plugin fails to check Item/Build permission

> The Parameterized Trigger Plugin for Jenkins fails to verify build permissions, allowing attackers to trigger arbitrary projects and potentially execute code.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mc22-25r3-2w9w

## What is CVE-2017-1000084?

CVE-2017-1000084 is a medium-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parameterized Trigger Plugin fails to check Item/Build permission: The Parameterized Trigger Plugin did not check the build authentication it was running as and allowed triggering any other project in Jenkins.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2017-1000084?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:parameterized-trigger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:parameterized-trigger` | Maven | All versions | 2.35.1 |
| `org.jenkins-ci.plugins:parameterized-trigger` | Maven | All versions | 2.35.1 |

Products: Jenkins Parameterized Trigger.

## How do I fix CVE-2017-1000084?

Upgrade org.jenkins-ci.plugins:parameterized-trigger to 2.35.1 or later.

## Is CVE-2017-1000084 being exploited?

There is no known exploitation of CVE-2017-1000084 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-27195](https://insights.sbomify.com/CVE-2022-27195/): Sensitive parameter values captured in build metadata files by Jenkins Parameterized Trigger Plugin (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000084 and fix it if it is affected.

What it is: CVE-2017-1000084 is a medium-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000084 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:parameterized-trigger (Maven): affected all versions; fixed in 2.35.1
- org.jenkins-ci.plugins:parameterized-trigger (Maven): affected all versions; fixed in 2.35.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000084/ (Markdown: https://insights.sbomify.com/CVE-2017-1000084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000084
- OSV: https://osv.dev/vulnerability/CVE-2017-1000084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000084/
Summaries are generated and may contain mistakes; the official description above is the record.
