{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000085 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:subversion to 2.9 or later.","what":"CVE-2017-1000085 is a medium-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000085 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000085 is a medium-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000085 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.9\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000085/ (Markdown: https://insights.sbomify.com/CVE-2017-1000085/index.md)","id":"CVE-2017-1000085","markdown":"https://insights.sbomify.com/CVE-2017-1000085/index.md","name":"CVE-2017-1000085","record":{"aliases":["GHSA-hrwc-pqfm-g6qf"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Subversion plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to force Jenkins users to connect to malicious servers, potentially capturing credentials without requiring direct access.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"subversion","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Subversion Plugin connects to a user-specified Subversion repository as part of form validation (e.g. to retrieve a list of tags). This functionality improperly checked permissions, allowing any user with Item/Build permission (but not Item/Configure) to connect to any web server or Subversion server and send credentials with a known ID, thereby possibly capturing them. Additionally, this functionality did not require POST requests be used, thereby allowing the above to be performed without direct access to Jenkins via Cross-Site Request Forgery attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Subversion Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2017-1000085","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Missing permission checks in Jenkins Periodic Backup Plugin allow every user to change settings","id":"CVE-2017-1000086"},"packages":[{"ecosystem":"Maven","fixed":["2.9"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":null,"source":"GHSA-hrwc-pqfm-g6qf"},{"ecosystem":"Maven","fixed":["2.9"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":"pkg:maven/org.jenkins-ci.plugins/subversion","source":"GHSA-hrwc-pqfm-g6qf"}],"prev":{"headline":"Parameterized Trigger Plugin fails to check Item/Build permission","id":"CVE-2017-1000084"},"products":["n/a"],"published":"2017-10-04","related":[{"cvss_score":7.5,"headline":"Path traversal vulnerability in Jenkins Subversion Plugin allows reading arbitrary files","id":"CVE-2021-21698","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":6.5,"headline":"XXE vulnerability in Jenkins Subversion Plugin","id":"CVE-2020-2304","kev_date_added":null,"published":"2020-11-04"},{"cvss_score":5.4,"headline":"Subversion Plugin stored XSS vulnerability","id":"CVE-2020-2111","kev_date_added":null,"published":"2020-02-12"},{"cvss_score":5.3,"headline":"Jenkins Subversion Plugin Incorrect Authorization vulnerability","id":"CVE-2018-1000111","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can exploit CSRF to force Jenkins users to connect to malicious servers, potentially capturing credentials without requiring direct access.","url":"https://insights.sbomify.com/CVE-2017-1000085/"}