# CVE-2017-1000085: Jenkins Subversion Plugin Cross-Site Request Forgery vulnerability

> Attackers can exploit CSRF to force Jenkins users to connect to malicious servers, potentially capturing credentials without requiring direct access.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hrwc-pqfm-g6qf

## What is CVE-2017-1000085?

CVE-2017-1000085 is a medium-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Subversion Plugin connects to a user-specified Subversion repository as part of form validation (e.g. to retrieve a list of tags). This functionality improperly checked permissions, allowing any user with Item/Build permission (but not Item/Configure) to connect to any web server or Subversion server and send credentials with a known ID, thereby possibly capturing them. Additionally, this functionality did not require POST requests be used, thereby allowing the above to be performed without direct access to Jenkins via Cross-Site Request Forgery attacks.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-1000085?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:subversion` | Maven | All versions | 2.9 |
| `org.jenkins-ci.plugins:subversion` | Maven | All versions | 2.9 |

Products: Jenkins Subversion.

## How do I fix CVE-2017-1000085?

Upgrade org.jenkins-ci.plugins:subversion to 2.9 or later.

## Is CVE-2017-1000085 being exploited?

There is no known exploitation of CVE-2017-1000085 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-21698](https://insights.sbomify.com/CVE-2021-21698/): Path traversal vulnerability in Jenkins Subversion Plugin allows reading arbitrary files (high 7.5)
- [CVE-2020-2304](https://insights.sbomify.com/CVE-2020-2304/): XXE vulnerability in Jenkins Subversion Plugin (medium 6.5)
- [CVE-2020-2111](https://insights.sbomify.com/CVE-2020-2111/): Subversion Plugin stored XSS vulnerability (medium 5.4)
- [CVE-2018-1000111](https://insights.sbomify.com/CVE-2018-1000111/): Jenkins Subversion Plugin Incorrect Authorization vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000085 and fix it if it is affected.

What it is: CVE-2017-1000085 is a medium-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000085 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.9
- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000085/ (Markdown: https://insights.sbomify.com/CVE-2017-1000085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000085
- OSV: https://osv.dev/vulnerability/CVE-2017-1000085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000085/
Summaries are generated and may contain mistakes; the official description above is the record.
