{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:periodicbackup. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000086 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:periodicbackup to 1.5 or later.","what":"CVE-2017-1000086 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000086 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000086 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000086 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:periodicbackup (Maven): affected all versions; fixed in 1.5\n- org.jenkins-ci.plugins:periodicbackup (Maven): affected all versions; fixed in 1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000086/ (Markdown: https://insights.sbomify.com/CVE-2017-1000086/index.md)","id":"CVE-2017-1000086","markdown":"https://insights.sbomify.com/CVE-2017-1000086/index.md","name":"CVE-2017-1000086","record":{"aliases":["GHSA-5293-3fgp-cr3x"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_modify","data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins backup plugin","requires_auth":"low_privilege","summary":"Attackers with read access can modify settings, trigger backups, and delete data due to missing permission checks and CSRF vulnerabilities.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"periodic_backup","vendor":"jenkins"}],"cvss":{"score":8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Periodic Backup Plugin did not perform any permission checks, allowing any user with Overall/Read access to change its settings, trigger backups, restore backups, download backups, and also delete all previous backups via log rotation. Additionally, the plugin was not requiring requests to its API be sent via POST, thereby opening itself to Cross-Site Request Forgery attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing permission checks in Jenkins Periodic Backup Plugin allow every user to change settings","id":"CVE-2017-1000086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins GitHub Branch Source Plugin allows any user with Overall/Read permission to get list of valid credentials IDs","id":"CVE-2017-1000087"},"packages":[{"ecosystem":"Maven","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:periodicbackup","purl":null,"source":"GHSA-5293-3fgp-cr3x"},{"ecosystem":"Maven","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:periodicbackup","purl":"pkg:maven/org.jenkins-ci.plugins/periodicbackup","source":"GHSA-5293-3fgp-cr3x"}],"prev":{"headline":"Jenkins Subversion Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2017-1000085"},"products":["n/a"],"published":"2017-10-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers with read access can modify settings, trigger backups, and delete data due to missing permission checks and CSRF vulnerabilities.","url":"https://insights.sbomify.com/CVE-2017-1000086/"}