# CVE-2017-1000086: Missing permission checks in Jenkins Periodic Backup Plugin allow every user to change settings

> Attackers with read access can modify settings, trigger backups, and delete data due to missing permission checks and CSRF vulnerabilities.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5293-3fgp-cr3x

## What is CVE-2017-1000086?

CVE-2017-1000086 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Periodic Backup Plugin did not perform any permission checks, allowing any user with Overall/Read access to change its settings, trigger backups, restore backups, download backups, and also delete all previous backups via log rotation. Additionally, the plugin was not requiring requests to its API be sent via POST, thereby opening itself to Cross-Site Request Forgery attacks.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2017-1000086?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:periodicbackup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:periodicbackup` | Maven | All versions | 1.5 |
| `org.jenkins-ci.plugins:periodicbackup` | Maven | All versions | 1.5 |

Products: Jenkins Periodic Backup.

## How do I fix CVE-2017-1000086?

Upgrade org.jenkins-ci.plugins:periodicbackup to 1.5 or later.

## Is CVE-2017-1000086 being exploited?

There is no known exploitation of CVE-2017-1000086 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000086 and fix it if it is affected.

What it is: CVE-2017-1000086 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000086 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:periodicbackup (Maven): affected all versions; fixed in 1.5
- org.jenkins-ci.plugins:periodicbackup (Maven): affected all versions; fixed in 1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000086/ (Markdown: https://insights.sbomify.com/CVE-2017-1000086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000086
- OSV: https://osv.dev/vulnerability/CVE-2017-1000086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000086/
Summaries are generated and may contain mistakes; the official description above is the record.
