# CVE-2017-1000088: Persisted XSS Vulnerability in Jenkins Sidebar Link Plugin

> Attackers can inject JavaScript into sidebar links, potentially executing arbitrary code in the context of other users.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-477r-v22q-r42f

## What is CVE-2017-1000088?

CVE-2017-1000088 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Sidebar Link plugin allows users able to configure jobs, views, and agents to add entries to the sidebar of these objects. There was no input validation, which meant users were able to use javascript: schemes for these links.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000088?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:sidebar-link. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:sidebar-link` | Maven | All versions | 1.9 |
| `org.jenkins-ci.plugins:sidebar-link` | Maven | All versions | 1.9 |

Products: Jenkins Sidebar Link.

## How do I fix CVE-2017-1000088?

Upgrade org.jenkins-ci.plugins:sidebar-link to 1.9 or later.

## Is CVE-2017-1000088 being exploited?

There is no known exploitation of CVE-2017-1000088 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-32985](https://insights.sbomify.com/CVE-2023-32985/): Jenkins Sidebar Link Plugin vulnerable to Path Traversal (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000088 and fix it if it is affected.

What it is: CVE-2017-1000088 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000088 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:sidebar-link (Maven): affected all versions; fixed in 1.9
- org.jenkins-ci.plugins:sidebar-link (Maven): affected all versions; fixed in 1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000088/ (Markdown: https://insights.sbomify.com/CVE-2017-1000088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000088
- OSV: https://osv.dev/vulnerability/CVE-2017-1000088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000088/
Summaries are generated and may contain mistakes; the official description above is the record.
