{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:role-strategy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000090 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:role-strategy to 2.5.1 or later.","what":"CVE-2017-1000090 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000090 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000090 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000090 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:role-strategy (Maven): affected all versions; fixed in 2.5.1\n- org.jenkins-ci.plugins:role-strategy (Maven): affected all versions; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000090/ (Markdown: https://insights.sbomify.com/CVE-2017-1000090/index.md)","id":"CVE-2017-1000090","markdown":"https://insights.sbomify.com/CVE-2017-1000090/index.md","name":"CVE-2017-1000090","record":{"aliases":["GHSA-774g-r3fm-4v85"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["privilege_escalation","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to grant admin roles to users or remove authorization, causing privilege escalation or denial of service in Jenkins.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"role-based_authorization_strategy","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Role-based Authorization Strategy Plugin was not requiring requests to its API be sent via POST, thereby opening itself to Cross-Site Request Forgery attacks. This allowed attackers to add administrator role to any user, or to remove the authorization configuration, preventing legitimate access to Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins Role-based Authorization Strategy Plugin configuration","id":"CVE-2017-1000090","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins GitHub Branch Source Plugin vulnerable to Cross-Site Request Forgery","id":"CVE-2017-1000091"},"packages":[{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:role-strategy","purl":null,"source":"GHSA-774g-r3fm-4v85"},{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:role-strategy","purl":"pkg:maven/org.jenkins-ci.plugins/role-strategy","source":"GHSA-774g-r3fm-4v85"}],"prev":{"headline":"Jenkins Build Step Plugin fails to check Item/Build permission","id":"CVE-2017-1000089"},"products":["n/a"],"published":"2017-10-04","related":[{"cvss_score":9.8,"headline":"Jenkins Role-based Authorization Strategy Plugin grants permissions even after they’ve been disabled","id":"CVE-2023-28668","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":8.8,"headline":"Improper authorization due to caching in Jenkins Role-based Authorization Strategy Plugin","id":"CVE-2020-2286","kev_date_added":null,"published":"2020-10-08"},{"cvss_score":4.3,"headline":"Incorrect permission checks in Jenkins Role-based Authorization Strategy Plugin may allow accessing some items","id":"CVE-2021-21624","kev_date_added":null,"published":"2021-03-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can exploit CSRF to grant admin roles to users or remove authorization, causing privilege escalation or denial of service in Jenkins.","url":"https://insights.sbomify.com/CVE-2017-1000090/"}