{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000092 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:git to 3.3.2 or later.","what":"CVE-2017-1000092 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000092 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000092 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000092 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.3.2\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000092/ (Markdown: https://insights.sbomify.com/CVE-2017-1000092/index.md)","id":"CVE-2017-1000092","markdown":"https://insights.sbomify.com/CVE-2017-1000092/index.md","name":"CVE-2017-1000092","record":{"aliases":["GHSA-rf5q-8gx3-xqfc"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Git Plugin","requires_auth":"none","summary":"Attackers can trick Jenkins users into leaking Git credentials to malicious servers via crafted URLs, requiring job configuration permissions to exploit.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"git","vendor":"jenkins"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Git Plugin connects to a user-specified Git repository as part of form validation. An attacker with no direct access to Jenkins but able to guess at a username/password credentials ID could trick a developer with job configuration permissions into following a link with a maliciously crafted Jenkins URL which would result in the Jenkins Git client sending the username and password to an attacker-controlled server.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery in Jenkins Git Plugin","id":"CVE-2017-1000092","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Poll SCM Plugin vulnerable to Cross-Site Request Forgery","id":"CVE-2017-1000093"},"packages":[{"ecosystem":"Maven","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":null,"source":"GHSA-rf5q-8gx3-xqfc"},{"ecosystem":"Maven","fixed":["3.3.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":"pkg:maven/org.jenkins-ci.plugins/git","source":"GHSA-rf5q-8gx3-xqfc"}],"prev":{"headline":"Jenkins GitHub Branch Source Plugin vulnerable to Cross-Site Request Forgery","id":"CVE-2017-1000091"},"products":["n/a"],"published":"2017-10-04","related":[{"cvss_score":8.8,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36882","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36883","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Path traversal in Jenkins Git Mercurial and Repo Plugins","id":"CVE-2022-30947","kev_date_added":null,"published":"2022-05-17"},{"cvss_score":6.5,"headline":"Improper masking of credentials Jenkins in Git Plugin","id":"CVE-2022-38663","kev_date_added":null,"published":"2022-08-23"},{"cvss_score":6.4,"headline":"Server-Side Request Forgery in Jenkins Git Plugin","id":"CVE-2018-1000182","kev_date_added":null,"published":"2018-06-05"},{"cvss_score":6.1,"headline":"Stored XSS vulnerability in Jenkins Git Plugin","id":"CVE-2021-21684","kev_date_added":null,"published":"2021-10-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can trick Jenkins users into leaking Git credentials to malicious servers via crafted URLs, requiring job configuration permissions to exploit.","url":"https://insights.sbomify.com/CVE-2017-1000092/"}