# CVE-2017-1000092: Cross-Site Request Forgery in Jenkins Git Plugin

> Attackers can trick Jenkins users into leaking Git credentials to malicious servers via crafted URLs, requiring job configuration permissions to exploit.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rf5q-8gx3-xqfc

## What is CVE-2017-1000092?

CVE-2017-1000092 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Git Plugin connects to a user-specified Git repository as part of form validation. An attacker with no direct access to Jenkins but able to guess at a username/password credentials ID could trick a developer with job configuration permissions into following a link with a maliciously crafted Jenkins URL which would result in the Jenkins Git client sending the username and password to an attacker-controlled server.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-1000092?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 3.3.2 |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 3.3.2 |

Products: Jenkins Git.

## How do I fix CVE-2017-1000092?

Upgrade org.jenkins-ci.plugins:git to 3.3.2 or later.

## Is CVE-2017-1000092 being exploited?

There is no known exploitation of CVE-2017-1000092 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36882](https://insights.sbomify.com/CVE-2022-36882/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 8.8)
- [CVE-2022-36883](https://insights.sbomify.com/CVE-2022-36883/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 7.5)
- [CVE-2022-30947](https://insights.sbomify.com/CVE-2022-30947/): Path traversal in Jenkins Git Mercurial and Repo Plugins (high 7.5)
- [CVE-2022-38663](https://insights.sbomify.com/CVE-2022-38663/): Improper masking of credentials Jenkins in Git Plugin (medium 6.5)
- [CVE-2018-1000182](https://insights.sbomify.com/CVE-2018-1000182/): Server-Side Request Forgery in Jenkins Git Plugin (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000092 and fix it if it is affected.

What it is: CVE-2017-1000092 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000092 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.3.2
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000092/ (Markdown: https://insights.sbomify.com/CVE-2017-1000092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000092
- OSV: https://osv.dev/vulnerability/CVE-2017-1000092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000092/
Summaries are generated and may contain mistakes; the official description above is the record.
