{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:pollscm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000093 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:pollscm to 1.3.1 or later.","what":"CVE-2017-1000093 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000093 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000093 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000093 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:pollscm (Maven): affected all versions; fixed in 1.3.1\n- org.jenkins-ci.plugins:pollscm (Maven): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000093/ (Markdown: https://insights.sbomify.com/CVE-2017-1000093/index.md)","id":"CVE-2017-1000093","markdown":"https://insights.sbomify.com/CVE-2017-1000093/index.md","name":"CVE-2017-1000093","record":{"aliases":["GHSA-fv3c-6cw7-2qcq"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Poll SCM Plugin","requires_auth":"none","summary":"Attackers can bypass permission checks to trigger project polling via CSRF, undermining the plugin's access control mechanisms.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"poll_scm","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Poll SCM Plugin was not requiring requests to its API be sent via POST, thereby opening itself to Cross-Site Request Forgery attacks. This allowed attackers to initiate polling of projects with a known name. While Jenkins in general does not consider polling to be a protection-worthy action as it's similar to cache invalidation, the plugin specifically adds a permission to be able to use this functionality, and this issue undermines that permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Poll SCM Plugin vulnerable to Cross-Site Request Forgery","id":"CVE-2017-1000093","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Docker Commons Plugin allows any user with Overall/Read permission to get list of valid credentials IDs","id":"CVE-2017-1000094"},"packages":[{"ecosystem":"Maven","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:pollscm","purl":null,"source":"GHSA-fv3c-6cw7-2qcq"},{"ecosystem":"Maven","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:pollscm","purl":"pkg:maven/org.jenkins-ci.plugins/pollscm","source":"GHSA-fv3c-6cw7-2qcq"}],"prev":{"headline":"Cross-Site Request Forgery in Jenkins Git Plugin","id":"CVE-2017-1000092"},"products":["n/a"],"published":"2017-10-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass permission checks to trigger project polling via CSRF, undermining the plugin's access control mechanisms.","url":"https://insights.sbomify.com/CVE-2017-1000093/"}