# CVE-2017-1000093: Jenkins Poll SCM Plugin vulnerable to Cross-Site Request Forgery

> Attackers can bypass permission checks to trigger project polling via CSRF, undermining the plugin's access control mechanisms.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-fv3c-6cw7-2qcq

## What is CVE-2017-1000093?

CVE-2017-1000093 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Poll SCM Plugin was not requiring requests to its API be sent via POST, thereby opening itself to Cross-Site Request Forgery attacks. This allowed attackers to initiate polling of projects with a known name. While Jenkins in general does not consider polling to be a protection-worthy action as it's similar to cache invalidation, the plugin specifically adds a permission to be able to use this functionality, and this issue undermines that permission.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-1000093?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:pollscm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:pollscm` | Maven | All versions | 1.3.1 |
| `org.jenkins-ci.plugins:pollscm` | Maven | All versions | 1.3.1 |

Products: Jenkins Poll Scm.

## How do I fix CVE-2017-1000093?

Upgrade org.jenkins-ci.plugins:pollscm to 1.3.1 or later.

## Is CVE-2017-1000093 being exploited?

There is no known exploitation of CVE-2017-1000093 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000093 and fix it if it is affected.

What it is: CVE-2017-1000093 is a high-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000093 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:pollscm (Maven): affected all versions; fixed in 1.3.1
- org.jenkins-ci.plugins:pollscm (Maven): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000093/ (Markdown: https://insights.sbomify.com/CVE-2017-1000093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000093
- OSV: https://osv.dev/vulnerability/CVE-2017-1000093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000093/
Summaries are generated and may contain mistakes; the official description above is the record.
