# CVE-2017-1000095: Unsafe methods in the default list of approved signatures in Jenkins Script Security Plugin

> Attackers can bypass Jenkins script sandbox restrictions to access private data or circumvent access controls via unsafe Groovy method whitelisting.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m68x-cc2f-gr5h, RHEA-2017:1716

## What is CVE-2017-1000095?

CVE-2017-1000095 is a medium-severity vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The default whitelist included the following unsafe entries: DefaultGroovyMethods.putAt(Object, String, Object); DefaultGroovyMethods.getAt(Object, String). These allowed circumventing many of the access restrictions implemented in the script sandbox by using e.g. currentBuild['rawBuild'] rather than currentBuild.rawBuild. Additionally, the following entries allowed accessing private data that would not be accessible otherwise due to script security: groovy.json.JsonOutput.toJson(Closure); groovy.json.JsonOutput.toJson(Object).

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2017-1000095?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.29.1 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.29.1 |
| `jenkins-plugin-script-security` | Red Hat:openshift:3.6::el7 | All versions | 0:1.29-1.el7 |

Products: Jenkins Script Security.

## How do I fix CVE-2017-1000095?

Upgrade org.jenkins-ci.plugins:script-security to 1.29.1 or later.

## Is CVE-2017-1000095 being exploited?

There is no known exploitation of CVE-2017-1000095 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000095 and fix it if it is affected.

What it is: CVE-2017-1000095 is a medium-severity vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000095 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.29.1
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000095/ (Markdown: https://insights.sbomify.com/CVE-2017-1000095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000095
- OSV: https://osv.dev/vulnerability/CVE-2017-1000095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000095/
Summaries are generated and may contain mistakes; the official description above is the record.
