# CVE-2017-1000102: Persistent XSS vulnerability in Static Analysis Utilities

> Attackers can inject malicious HTML into the Details view of Static Analysis Utilities plugins via manipulated console output, potentially executing scripts in the user's browser.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9c2p-99pg-c4j9

## What is CVE-2017-1000102?

CVE-2017-1000102 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Details view of some Static Analysis Utilities based plugins, was vulnerable to a persisted cross-site scripting vulnerability: Malicious users able to influence the input to these plugins, for example the console output which is parsed to extract build warnings (Warnings Plugin), could insert arbitrary HTML into this view.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000102?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:analysis-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:analysis-core` | Maven | All versions | 1.92 |
| `org.jvnet.hudson.plugins:analysis-core` | Maven | All versions | 1.92 |

Products: Jenkins Static Analysis Utilities.

## How do I fix CVE-2017-1000102?

Upgrade org.jvnet.hudson.plugins:analysis-core to 1.92 or later.

## Is CVE-2017-1000102 being exploited?

There is no known exploitation of CVE-2017-1000102 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10307](https://insights.sbomify.com/CVE-2019-10307/): Jenkins Static Analysis Utilities Plugin is vulnerable to Cross-site request forgery vulnerability (medium 6.5)
- [CVE-2019-10308](https://insights.sbomify.com/CVE-2019-10308/): Missing permission check in Jenkins Static Analysis Utilities Plugin (medium 6.5)
- [CVE-2020-2316](https://insights.sbomify.com/CVE-2020-2316/): Stored XSS vulnerability in Jenkins Static Analysis Utilities Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000102 and fix it if it is affected.

What it is: CVE-2017-1000102 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000102 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:analysis-core (Maven): affected all versions; fixed in 1.92
- org.jvnet.hudson.plugins:analysis-core (Maven): affected all versions; fixed in 1.92

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000102/ (Markdown: https://insights.sbomify.com/CVE-2017-1000102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000102
- OSV: https://osv.dev/vulnerability/CVE-2017-1000102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000102/
Summaries are generated and may contain mistakes; the official description above is the record.
