# CVE-2017-1000103: Persistent XSS vulnerability in Jenkins DRY Plugin

> Attackers can inject arbitrary HTML into the Static Analysis Utilities DRY Plugin's Details view, potentially executing scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-63cj-3r94-234v

## What is CVE-2017-1000103?

CVE-2017-1000103 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The custom Details view of the Static Analysis Utilities based DRY Plugin, was vulnerable to a persisted cross-site scripting vulnerability: Malicious users able to influence the input to this plugin could insert arbitrary HTML into this view.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000103?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:dry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:dry` | Maven | All versions | 2.49 |
| `org.jvnet.hudson.plugins:dry` | Maven | All versions | 2.49 |

Products: Jenkins Dry.

## How do I fix CVE-2017-1000103?

Upgrade org.jvnet.hudson.plugins:dry to 2.49 or later.

## Is CVE-2017-1000103 being exploited?

There is no known exploitation of CVE-2017-1000103 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000010](https://insights.sbomify.com/CVE-2018-1000010/): XXE vulnerability in Jenkins DRY Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000103 and fix it if it is affected.

What it is: CVE-2017-1000103 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000103 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:dry (Maven): affected all versions; fixed in 2.49
- org.jvnet.hudson.plugins:dry (Maven): affected all versions; fixed in 2.49

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000103/ (Markdown: https://insights.sbomify.com/CVE-2017-1000103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000103
- OSV: https://osv.dev/vulnerability/CVE-2017-1000103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000103/
Summaries are generated and may contain mistakes; the official description above is the record.
