# CVE-2017-1000104: Improper Privilege Management in Jenkins Config File Provider Plugin

> Users with read-only access could view sensitive configuration files containing secrets due to missing authorization checks in the Config File Provider Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-6h72-m3xw-fp3c

## What is CVE-2017-1000104?

CVE-2017-1000104 is a medium-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Config File Provider Plugin is used to centrally manage configuration files that often include secrets, such as passwords. Users with only Overall/Read access to Jenkins were able to access URLs directly that allowed viewing these files. Access to view these files now requires sufficient permissions to configure the provided files, view the configuration of the folder in which the configuration files are defined, or have Job/Configure permissions to a job able to use these files.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2017-1000104?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:config-file-provider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:config-file-provider` | Maven | All versions | 2.16.2 |
| `org.jenkins-ci.plugins:config-file-provider` | Maven | All versions | 2.16.2 |

Products: Jenkins Config File Provider.

## How do I fix CVE-2017-1000104?

Upgrade org.jenkins-ci.plugins:config-file-provider to 2.16.2 or later.

## Is CVE-2017-1000104 being exploited?

There is no known exploitation of CVE-2017-1000104 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-21642](https://insights.sbomify.com/CVE-2021-21642/): XML External Entity Reference vulnerability in Jenkins Config File Provider Plugin (high 8.1)
- [CVE-2018-1000414](https://insights.sbomify.com/CVE-2018-1000414/): CSRF vulnerability in Config File Provider Plugin (high 8.1)
- [CVE-2023-40339](https://insights.sbomify.com/CVE-2023-40339/): Jenkins Config File Provider Plugin improper credential masking vulnerability (high 7.5)
- [CVE-2021-21643](https://insights.sbomify.com/CVE-2021-21643/): Incorrect permission checks in Jenkins Config File Provider Plugin allow enumerating credentials IDs (medium 6.5)
- [CVE-2021-21644](https://insights.sbomify.com/CVE-2021-21644/): CSRF vulnerability in Jenkins Config File Provider Plugin allows deleting configuration files (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000104 and fix it if it is affected.

What it is: CVE-2017-1000104 is a medium-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000104 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 2.16.2
- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 2.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000104/ (Markdown: https://insights.sbomify.com/CVE-2017-1000104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000104
- OSV: https://osv.dev/vulnerability/CVE-2017-1000104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000104/
Summaries are generated and may contain mistakes; the official description above is the record.
