# CVE-2017-1000107: Sandbox bypass in Jenkins Script Security Plugin sandbox bypass

> Attackers can bypass sandbox restrictions to execute arbitrary code via constructor invocations in the Jenkins Script Security Plugin.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h7rx-r733-7x7r

## What is CVE-2017-1000107?

CVE-2017-1000107 is a high-severity code injection vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Script Security Plugin did not apply sandboxing restrictions to constructor invocations via positional arguments list, super constructor invocations, method references, and type coercion expressions. This could be used to invoke arbitrary constructors and methods, bypassing sandbox protection.

## Which versions are affected by CVE-2017-1000107?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.31 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.31 |

Products: Jenkins Script Security.

## How do I fix CVE-2017-1000107?

Upgrade org.jenkins-ci.plugins:script-security to 1.31 or later.

## Is CVE-2017-1000107 being exploited?

There is no known exploitation of CVE-2017-1000107 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000107 and fix it if it is affected.

What it is: CVE-2017-1000107 is a high-severity code injection vulnerability in n/a, published on 4 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000107 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.31
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000107/ (Markdown: https://insights.sbomify.com/CVE-2017-1000107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000107
- OSV: https://osv.dev/vulnerability/CVE-2017-1000107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000107/
Summaries are generated and may contain mistakes; the official description above is the record.
