{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:pipeline-input-step. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000108 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:pipeline-input-step to 2.7 or later.","what":"CVE-2017-1000108 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000108 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000108 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000108 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:pipeline-input-step (Maven): affected all versions; fixed in 2.7\n- org.jenkins-ci.plugins:pipeline-input-step (Maven): affected all versions; fixed in 2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000108/ (Markdown: https://insights.sbomify.com/CVE-2017-1000108/index.md)","id":"CVE-2017-1000108","markdown":"https://insights.sbomify.com/CVE-2017-1000108/index.md","name":"CVE-2017-1000108","record":{"aliases":["GHSA-hxpw-7x95-q38m"],"analysis":{"component_type":"developer_tool","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Pipeline Plugin","requires_auth":"none","summary":"Jenkins Pipeline Input Step allowed read-only users to provide input, bypassing build permissions; attackers can manipulate pipeline execution without proper authorization.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pipeline-input-step","vendor":"jenkins"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Pipeline: Input Step Plugin by default allowed users with Item/Read access to a pipeline to interact with the step to provide input. This has been changed, and now requires users to have the Item/Build permission instead.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Pipeline: Input Step Plugin","id":"CVE-2017-1000108","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Persistent XSS vulnerability in Jenkins OWASP Dependency-Check Plugin","id":"CVE-2017-1000109"},"packages":[{"ecosystem":"Maven","fixed":["2.7"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:pipeline-input-step","purl":null,"source":"GHSA-hxpw-7x95-q38m"},{"ecosystem":"Maven","fixed":["2.7"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:pipeline-input-step","purl":"pkg:maven/org.jenkins-ci.plugins/pipeline-input-step","source":"GHSA-hxpw-7x95-q38m"}],"prev":{"headline":"Sandbox bypass in Jenkins Script Security Plugin sandbox bypass","id":"CVE-2017-1000107"},"products":["n/a"],"published":"2017-10-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Jenkins Pipeline Input Step allowed read-only users to provide input, bypassing build permissions; attackers can manipulate pipeline execution without proper authorization.","url":"https://insights.sbomify.com/CVE-2017-1000108/"}