# CVE-2017-1000108: Jenkins Pipeline: Input Step Plugin

> Jenkins Pipeline Input Step allowed read-only users to provide input, bypassing build permissions; attackers can manipulate pipeline execution without proper authorization.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-hxpw-7x95-q38m

## What is CVE-2017-1000108?

CVE-2017-1000108 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Pipeline: Input Step Plugin by default allowed users with Item/Read access to a pipeline to interact with the step to provide input. This has been changed, and now requires users to have the Item/Build permission instead.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-1000108?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:pipeline-input-step. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:pipeline-input-step` | Maven | All versions | 2.7 |
| `org.jenkins-ci.plugins:pipeline-input-step` | Maven | All versions | 2.7 |

Products: Jenkins Pipeline-Input-Step.

## How do I fix CVE-2017-1000108?

Upgrade org.jenkins-ci.plugins:pipeline-input-step to 2.7 or later.

## Is CVE-2017-1000108 being exploited?

There is no known exploitation of CVE-2017-1000108 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000108 and fix it if it is affected.

What it is: CVE-2017-1000108 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000108 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:pipeline-input-step (Maven): affected all versions; fixed in 2.7
- org.jenkins-ci.plugins:pipeline-input-step (Maven): affected all versions; fixed in 2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000108/ (Markdown: https://insights.sbomify.com/CVE-2017-1000108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000108
- OSV: https://osv.dev/vulnerability/CVE-2017-1000108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000108/
Summaries are generated and may contain mistakes; the official description above is the record.
