# CVE-2017-1000109: Persistent XSS vulnerability in Jenkins OWASP Dependency-Check Plugin

> Attackers can inject arbitrary HTML into the Static Analysis Utilities plugin view, potentially executing scripts in victim browsers.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-65cq-whr4-7c2v

## What is CVE-2017-1000109?

CVE-2017-1000109 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The custom Details view of the Static Analysis Utilities based OWASP Dependency-Check Plugin, was vulnerable to a persisted cross-site scripting vulnerability: Malicious users able to influence the input to this plugin could insert arbitrary HTML into this view.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000109?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:dependency-check-jenkins-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:dependency-check-jenkins-plugin` | Maven | All versions | 2.0.1.2 |
| `org.jenkins-ci.plugins:dependency-check-jenkins-plugin` | Maven | All versions | 2.0.1.2 |

Products: Jenkins Owasp Dependency-Check.

## How do I fix CVE-2017-1000109?

Upgrade org.jenkins-ci.plugins:dependency-check-jenkins-plugin to 2.0.1.2 or later.

## Is CVE-2017-1000109 being exploited?

There is no known exploitation of CVE-2017-1000109 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-28153](https://insights.sbomify.com/CVE-2024-28153/): Jenkins OWASP Dependency-Check Plugin has stored XSS vulnerability (high 7.3)
- [CVE-2021-43577](https://insights.sbomify.com/CVE-2021-43577/): XXE vulnerability in Jenkins OWASP Dependency-Check Plugin (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000109 and fix it if it is affected.

What it is: CVE-2017-1000109 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000109 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 2.0.1.2
- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 2.0.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000109/ (Markdown: https://insights.sbomify.com/CVE-2017-1000109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000109
- OSV: https://osv.dev/vulnerability/CVE-2017-1000109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000109/
Summaries are generated and may contain mistakes; the official description above is the record.
