# CVE-2017-1000114: Exposure of Sensitive Information in Jenkins Datadog plugin

> Attackers can steal Datadog API keys transmitted in plaintext during Jenkins configuration, potentially compromising monitoring services.

- **Severity:** Low 3.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hf7w-f4h4-9xp8

## What is CVE-2017-1000114?

CVE-2017-1000114 is a low-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Datadog Plugin stores an API key to access the Datadog service in the global Jenkins configuration. While the API key is stored encrypted on disk, it was transmitted in plain text as part of the configuration form. This could result in exposure of the API key for example through browser extensions or cross-site scripting vulnerabilities. The Datadog Plugin now encrypts the API key transmitted to administrators viewing the global configuration form.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-1000114?

2 open source packages ship an affected version, including org.datadog.jenkins.plugins:datadog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.datadog.jenkins.plugins:datadog` | Maven | All versions | 0.6.2 |
| `org.datadog.jenkins.plugins:datadog` | Maven | All versions | 0.6.2 |

Products: Jenkins Datadog.

## How do I fix CVE-2017-1000114?

Upgrade org.datadog.jenkins.plugins:datadog to 0.6.2 or later.

## Is CVE-2017-1000114 being exploited?

There is no known exploitation of CVE-2017-1000114 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-37944](https://insights.sbomify.com/CVE-2023-37944/): Jenkins Datadog Plugin does not perform a permission check in an HTTP endpoint. (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000114 and fix it if it is affected.

What it is: CVE-2017-1000114 is a low-severity vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000114 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.datadog.jenkins.plugins:datadog (Maven): affected all versions; fixed in 0.6.2
- org.datadog.jenkins.plugins:datadog (Maven): affected all versions; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000114/ (Markdown: https://insights.sbomify.com/CVE-2017-1000114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000114
- OSV: https://osv.dev/vulnerability/CVE-2017-1000114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000114/
Summaries are generated and may contain mistakes; the official description above is the record.
