CVE-2017-1000118 Improper Restriction of Operations within the Bounds of a Memory Buffer in akka-http-core
Attackers can cause a Denial of Service in Akka HTTP by sending a malformed Accept header, leading to a StackOverflowError.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-1000118?
CVE-2017-1000118 is a high-severity denial of service vulnerability in n/a, published on 4 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
Weakness: CWE-119
Which versions are affected by CVE-2017-1000118?
4 open source packages ship an affected version, including com.typesafe.akka:akka-http-core_2.11 and com.typesafe.akka:akka-http-core_2.12. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.typesafe.akka:akka-http-core_2.11 Maven | All versions | 10.0.6 |
com.typesafe.akka:akka-http-core_2.11 Maven | All versions | 10.0.6 |
com.typesafe.akka:akka-http-core_2.12 Maven | All versions | 10.0.6 |
com.typesafe.akka:akka-http-core_2.12 Maven | All versions | 10.0.6 |
Products include Akka Http Server.
How do I fix CVE-2017-1000118?
Upgrade com.typesafe.akka:akka-http-core_2.11 to 10.0.6 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-1000118 being exploited?
There is no known exploitation of CVE-2017-1000118 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-gfx6-ph4q-q54q.