{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000159 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-1000159 is a high-severity command injection vulnerability in n/a, published on 27 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000159 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000159 is a high-severity command injection vulnerability in n/a, published on 27 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000159 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000159/ (Markdown: https://insights.sbomify.com/CVE-2017-1000159/index.md)","id":"CVE-2017-1000159","markdown":"https://insights.sbomify.com/CVE-2017-1000159/index.md","name":"CVE-2017-1000159","record":{"aliases":["DEBIAN-CVE-2017-1000159","DLA-1204-1","GHSA-vvj5-83p2-x3pp","MGASA-2017-0450","SUSE-SU-2018:0639-1","SUSE-SU-2018:0947-1","UBUNTU-CVE-2017-1000159","USN-3503-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Evince document viewer","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via crafted filenames when printing to PDF in Evince, requiring users to update the application.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"evince","vendor":"gnome"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Software Development Kit 11 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP3","SUSE:Linux Enterprise Workstation Extension 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2017-1000159","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2017"},"n_packages":8,"n_references":7,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000160"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["3.20.2-6.22.9"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:0947-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["2.28.2-0.7.3.1"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2018:0639-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["3.20.2-6.22.9"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:0947-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["2.28.2-0.7.3.1"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2018:0639-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["3.20.2-6.22.9"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:0947-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["2.28.2-0.7.3.1"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2018:0639-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["3.20.2-6.22.9"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:0947-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP3","fixed":["3.20.2-6.22.9"],"introduced":["0"],"last_affected":[],"package":"evince","purl":"pkg:rpm/suse/evince\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP3","source":"SUSE-SU-2018:0947-1"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2017-1000158"},"products":["n/a"],"published":"2017-11-27","related":[{"cvss_score":6.8,"headline":"Memory corruption in n/a","id":"CVE-2011-0433","kev_date_added":null,"published":"2012-11-19"},{"cvss_score":6.8,"headline":"Integer overflow in n/a","id":"CVE-2011-5244","kev_date_added":null,"published":"2012-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via crafted filenames when printing to PDF in Evince, requiring users to update the application.","url":"https://insights.sbomify.com/CVE-2017-1000159/"}