{"answers":{"affected":"2 open source packages ship an affected version, including ejs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000188 in the wild and no public exploit code.","fix":"Upgrade ejs to 2.5.5 or later.","what":"CVE-2017-1000188 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000188 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000188 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000188 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ejs (npm): affected all versions; fixed in 2.5.5\n- ejs (npm): affected all versions; fixed in 2.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000188/ (Markdown: https://insights.sbomify.com/CVE-2017-1000188/index.md)","id":"CVE-2017-1000188","markdown":"https://insights.sbomify.com/CVE-2017-1000188/index.md","name":"CVE-2017-1000188","record":{"aliases":["DEBIAN-CVE-2017-1000188","GHSA-hwcf-pp87-7x6p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js EJS library","requires_auth":"none","summary":"Attackers can inject malicious scripts via the renderFile function in the EJS template engine, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ejs","vendor":"ejs"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mde ejs vulnerable to XSS","id":"CVE-2017-1000188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"ejs vulnerable to DoS due to weak input validation","id":"CVE-2017-1000189"},"packages":[{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"ejs","purl":null,"source":"GHSA-hwcf-pp87-7x6p"},{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"ejs","purl":"pkg:npm/ejs","source":"GHSA-hwcf-pp87-7x6p"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-1000187"},"products":["n/a"],"published":"2017-11-17","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2023-29827","kev_date_added":null,"published":"2023-05-04"},{"cvss_score":9.8,"headline":"ejs template injection vulnerability","id":"CVE-2022-29078","kev_date_added":null,"published":"2022-04-25"},{"cvss_score":9.8,"headline":"ejs is vulnerable to remote code execution due to weak input validation","id":"CVE-2017-1000228","kev_date_added":null,"published":"2017-11-17"},{"cvss_score":7.5,"headline":"ejs vulnerable to DoS due to weak input validation","id":"CVE-2017-1000189","kev_date_added":null,"published":"2017-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via the renderFile function in the EJS template engine, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2017-1000188/"}