{"answers":{"affected":"2 open source packages ship an affected version, including ejs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000189 in the wild and no public exploit code.","fix":"Upgrade ejs to 2.5.5 or later.","what":"CVE-2017-1000189 is a high-severity denial of service vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000189 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000189 is a high-severity denial of service vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000189 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ejs (npm): affected all versions; fixed in 2.5.5\n- ejs (npm): affected all versions; fixed in 2.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000189/ (Markdown: https://insights.sbomify.com/CVE-2017-1000189/index.md)","id":"CVE-2017-1000189","markdown":"https://insights.sbomify.com/CVE-2017-1000189/index.md","name":"CVE-2017-1000189","record":{"aliases":["DEBIAN-CVE-2017-1000189","GHSA-6x77-rpqf-j6mw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js EJS library","requires_auth":"none","summary":"Attackers can cause a denial of service in applications using the EJS library due to weak input validation in the renderFile function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ejs","vendor":"ejs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ejs vulnerable to DoS due to weak input validation","id":"CVE-2017-1000189","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"SimpleXML has XML External Entity (XXE) vulnerability","id":"CVE-2017-1000190"},"packages":[{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"ejs","purl":null,"source":"GHSA-6x77-rpqf-j6mw"},{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"ejs","purl":"pkg:npm/ejs","source":"GHSA-6x77-rpqf-j6mw"}],"prev":{"headline":"mde ejs vulnerable to XSS","id":"CVE-2017-1000188"},"products":["n/a"],"published":"2017-11-17","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2023-29827","kev_date_added":null,"published":"2023-05-04"},{"cvss_score":9.8,"headline":"ejs template injection vulnerability","id":"CVE-2022-29078","kev_date_added":null,"published":"2022-04-25"},{"cvss_score":9.8,"headline":"ejs is vulnerable to remote code execution due to weak input validation","id":"CVE-2017-1000228","kev_date_added":null,"published":"2017-11-17"},{"cvss_score":6.1,"headline":"mde ejs vulnerable to XSS","id":"CVE-2017-1000188","kev_date_added":null,"published":"2017-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in applications using the EJS library due to weak input validation in the renderFile function.","url":"https://insights.sbomify.com/CVE-2017-1000189/"}