# CVE-2017-1000189: ejs vulnerable to DoS due to weak input validation

> Attackers can cause a denial of service in applications using the EJS library due to weak input validation in the renderFile function.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1000189, GHSA-6x77-rpqf-j6mw

## What is CVE-2017-1000189?

CVE-2017-1000189 is a high-severity denial of service vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-1000189?

2 open source packages ship an affected version, including ejs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ejs` | npm | All versions | 2.5.5 |
| `ejs` | npm | All versions | 2.5.5 |

Products: Ejs Ejs.

## How do I fix CVE-2017-1000189?

Upgrade ejs to 2.5.5 or later.

## Is CVE-2017-1000189 being exploited?

There is no known exploitation of CVE-2017-1000189 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-29827](https://insights.sbomify.com/CVE-2023-29827/): Code injection in n/a (critical 9.8)
- [CVE-2022-29078](https://insights.sbomify.com/CVE-2022-29078/): ejs template injection vulnerability (critical 9.8)
- [CVE-2017-1000228](https://insights.sbomify.com/CVE-2017-1000228/): ejs is vulnerable to remote code execution due to weak input validation (critical 9.8)
- [CVE-2017-1000188](https://insights.sbomify.com/CVE-2017-1000188/): mde ejs vulnerable to XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000189 and fix it if it is affected.

What it is: CVE-2017-1000189 is a high-severity denial of service vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000189 in the wild and no public exploit code.

Affected packages and fixed versions:
- ejs (npm): affected all versions; fixed in 2.5.5
- ejs (npm): affected all versions; fixed in 2.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000189/ (Markdown: https://insights.sbomify.com/CVE-2017-1000189/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000189
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000189
- OSV: https://osv.dev/vulnerability/CVE-2017-1000189

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000189/
Summaries are generated and may contain mistakes; the official description above is the record.
