{"answers":{"affected":"4 open source packages ship an affected version, including io.swagger:swagger-codegen and io.swagger:swagger-parser. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-1000208 in the wild and no public exploit code.","fix":"Upgrade io.swagger:swagger-codegen to 2.2.2 or later.","what":"CVE-2017-1000208 is a high-severity unsafe deserialization vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000208 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000208 is a high-severity unsafe deserialization vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000208 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.swagger:swagger-codegen (Maven): affected all versions; fixed in 2.2.2\n- io.swagger:swagger-codegen (Maven): affected all versions; fixed in 2.2.2\n- io.swagger:swagger-parser (Maven): affected all versions; fixed in 1.0.31\n- io.swagger:swagger-parser (Maven): affected all versions; fixed in 1.0.31\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000208/ (Markdown: https://insights.sbomify.com/CVE-2017-1000208/index.md)","id":"CVE-2017-1000208","markdown":"https://insights.sbomify.com/CVE-2017-1000208/index.md","name":"CVE-2017-1000208","record":{"aliases":["GHSA-q7pf-qr96-2vq5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Swagger Parser library","requires_auth":"none","summary":"Attackers can execute arbitrary code by providing a malicious YAML Open-API specification to the Swagger Parser library.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"swagger-codegen","vendor":"swagger"},{"product":"swagger-parser","vendor":"swagger"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A vulnerability in Swagger-Parser's (version \u003c= 1.0.30) yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (\u003c= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of Untrusted Data in swagger-parser","id":"CVE-2017-1000208","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2017"},"n_packages":4,"n_references":2,"next":{"headline":"nv-websocket-client allows attackers to spoof SSL/TLS servers via an arbitrary valid certificate","id":"CVE-2017-1000209"},"packages":[{"ecosystem":"Maven","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"io.swagger:swagger-codegen","purl":null,"source":"GHSA-q7pf-qr96-2vq5"},{"ecosystem":"Maven","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"io.swagger:swagger-codegen","purl":"pkg:maven/io.swagger/swagger-codegen","source":"GHSA-q7pf-qr96-2vq5"},{"ecosystem":"Maven","fixed":["1.0.31"],"introduced":["0"],"last_affected":[],"package":"io.swagger:swagger-parser","purl":null,"source":"GHSA-q7pf-qr96-2vq5"},{"ecosystem":"Maven","fixed":["1.0.31"],"introduced":["0"],"last_affected":[],"package":"io.swagger:swagger-parser","purl":"pkg:maven/io.swagger/swagger-parser","source":"GHSA-q7pf-qr96-2vq5"}],"prev":{"headline":"Deserialization of Untrusted Data in swagger-codegen","id":"CVE-2017-1000207"},"products":["n/a"],"published":"2017-11-17","related":[{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in swagger-codegen","id":"CVE-2017-1000207","kev_date_added":null,"published":"2017-11-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by providing a malicious YAML Open-API specification to the Swagger Parser library.","url":"https://insights.sbomify.com/CVE-2017-1000208/"}