{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000211 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-1000211 is a medium-severity use after free vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000211 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000211 is a medium-severity use after free vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000211 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000211/ (Markdown: https://insights.sbomify.com/CVE-2017-1000211/index.md)","id":"CVE-2017-1000211","markdown":"https://insights.sbomify.com/CVE-2017-1000211/index.md","name":"CVE-2017-1000211","record":{"aliases":["DEBIAN-CVE-2017-1000211","DLA-1175-1","GHSA-6qv4-ghq2-3r52","MGASA-2017-0451","SUSE-SU-2017:3180-1","UBUNTU-CVE-2017-1000211"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Lynx text browser","requires_auth":"none","summary":"A use-after-free flaw in the Lynx text browser's HTML parser allows attackers to disclose memory contents.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"lynx","vendor":"lynx_project"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.","ecosystems":["SUSE:Linux Enterprise Software Development Kit 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2017-1000211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"use_after_free","year":"2017"},"n_packages":1,"n_references":4,"next":{"headline":"alchemist.vim vulnerable to remote code execution","id":"CVE-2017-1000212"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["2.8.6-146.3.1"],"introduced":["0"],"last_affected":[],"package":"lynx","purl":"pkg:rpm/suse/lynx\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2017:3180-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-1000210"},"products":["n/a"],"published":"2017-11-17","related":[{"cvss_score":7.8,"headline":"lynx doesn't properly sanitize user input and exposes database password to unauthorized users","id":"CVE-2014-5002","kev_date_added":null,"published":"2018-01-10"},{"cvss_score":7.8,"headline":"Command injection in n/a","id":"CVE-1999-1549","kev_date_added":null,"published":"2001-09-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A use-after-free flaw in the Lynx text browser's HTML parser allows attackers to disclose memory contents.","url":"https://insights.sbomify.com/CVE-2017-1000211/"}