{"answers":{"affected":"2 open source packages ship an affected version, including alchemist.vim. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000212 in the wild and no public exploit code.","fix":"Upgrade alchemist.vim to 1.3.2 or later.","what":"CVE-2017-1000212 is a critical code injection vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000212 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000212 is a critical code injection vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000212 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- alchemist.vim (Hex): affected all versions; fixed in 1.3.2\n- alchemist.vim (Hex): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000212/ (Markdown: https://insights.sbomify.com/CVE-2017-1000212/index.md)","id":"CVE-2017-1000212","markdown":"https://insights.sbomify.com/CVE-2017-1000212/index.md","name":"CVE-2017-1000212","record":{"aliases":["GHSA-6x65-vqp7-5r63"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir Vim plugin","requires_auth":"none","summary":"A malicious website can execute arbitrary Elixir code via the bundled server in the Alchemist Vim plugin, allowing remote code execution on the developer's machine.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"alchemist-server","vendor":"alchemist-elixir"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"Elixir's vim plugin, alchemist.vim is vulnerable to remote code execution in the bundled alchemist-server. A malicious website can execute requests against an ephemeral port on localhost that are then evaluated as elixir code.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"alchemist.vim vulnerable to remote code execution","id":"CVE-2017-1000212","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000213"},"packages":[{"ecosystem":"Hex","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"alchemist.vim","purl":null,"source":"GHSA-6x65-vqp7-5r63"},{"ecosystem":"Hex","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"alchemist.vim","purl":"pkg:hex/alchemist.vim","source":"GHSA-6x65-vqp7-5r63"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2017-1000211"},"products":["n/a"],"published":"2017-11-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"A malicious website can execute arbitrary Elixir code via the bundled server in the Alchemist Vim plugin, allowing remote code execution on the developer's machine.","url":"https://insights.sbomify.com/CVE-2017-1000212/"}