CVE-2017-1000217 Opencast RCE Vulnerability
Attackers can inject scripts via media metadata in Opencast, leading to arbitrary code execution in the player and media modules.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-1000217?
CVE-2017-1000217 is a high-severity cross-site scripting vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting in arbitrary code execution, fixed in 2.3.3 and 3.0.
Weakness: CWE-74
Which versions are affected by CVE-2017-1000217?
2 open source packages ship an affected version, including org.opencastproject:base. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.opencastproject:base Maven | All versions | 2.3.3 |
org.opencastproject:base Maven | All versions | 2.3.3 |
Products include Opencast Opencast.
How do I fix CVE-2017-1000217?
Upgrade org.opencastproject:base to 2.3.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-1000217 being exploited?
There is no known exploitation of CVE-2017-1000217 in the wild and no public exploit code.
Sources
Also known as GHSA-qwfv-5jwj-582h.