{"answers":{"affected":"2 open source packages ship an affected version, including org.opencastproject:base. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000217 in the wild and no public exploit code.","fix":"Upgrade org.opencastproject:base to 2.3.3 or later.","what":"CVE-2017-1000217 is a high-severity cross-site scripting vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000217 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000217 is a high-severity cross-site scripting vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000217 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opencastproject:base (Maven): affected all versions; fixed in 2.3.3\n- org.opencastproject:base (Maven): affected all versions; fixed in 2.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000217/ (Markdown: https://insights.sbomify.com/CVE-2017-1000217/index.md)","id":"CVE-2017-1000217","markdown":"https://insights.sbomify.com/CVE-2017-1000217/index.md","name":"CVE-2017-1000217","record":{"aliases":["GHSA-qwfv-5jwj-582h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Opencast media platform","requires_auth":"none","summary":"Attackers can inject scripts via media metadata in Opencast, leading to arbitrary code execution in the player and media modules.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opencast","vendor":"opencast"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting in arbitrary code execution, fixed in 2.3.3 and 3.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Opencast RCE Vulnerability","id":"CVE-2017-1000217","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2017-1000218"},"packages":[{"ecosystem":"Maven","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"org.opencastproject:base","purl":null,"source":"GHSA-qwfv-5jwj-582h"},{"ecosystem":"Maven","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"org.opencastproject:base","purl":"pkg:maven/org.opencastproject/base","source":"GHSA-qwfv-5jwj-582h"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2017-1000215"},"products":["n/a"],"published":"2017-11-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can inject scripts via media metadata in Opencast, leading to arbitrary code execution in the player and media modules.","url":"https://insights.sbomify.com/CVE-2017-1000217/"}