CVE-2017-1000220 PIDUsage Enables OS Command Injection

Critical 9.8 Published Updated

Attackers can execute arbitrary commands via the pidusage library, requiring developers to upgrade to a patched version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000220?

CVE-2017-1000220 is a critical command injection vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution

Weakness: CWE-78

Which versions are affected by CVE-2017-1000220?

2 open source packages ship an affected version, including pidusage. It affects 1 product.

PackageAffectedFixed in
pidusage npmAll versions1.1.5
pidusage npmAll versions1.1.5

Products include Pidusage Project Pidusage.

How do I fix CVE-2017-1000220?

Upgrade pidusage to 1.1.5 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2017-1000220 being exploited?

There is no known exploitation of CVE-2017-1000220 in the wild and no public exploit code.

Sources

Also known as GHSA-h2p3-h48h-9jj7.

Is CVE-2017-1000220 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free