{"answers":{"affected":"2 open source packages ship an affected version, including pidusage. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000220 in the wild and no public exploit code.","fix":"Upgrade pidusage to 1.1.5 or later.","what":"CVE-2017-1000220 is a critical command injection vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000220 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000220 is a critical command injection vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000220 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pidusage (npm): affected all versions; fixed in 1.1.5\n- pidusage (npm): affected all versions; fixed in 1.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000220/ (Markdown: https://insights.sbomify.com/CVE-2017-1000220/index.md)","id":"CVE-2017-1000220","markdown":"https://insights.sbomify.com/CVE-2017-1000220/index.md","name":"CVE-2017-1000220","record":{"aliases":["GHSA-h2p3-h48h-9jj7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js process monitoring library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via the pidusage library, requiring developers to upgrade to a patched version.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pidusage","vendor":"pidusage_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"soyuka/pidusage \u003c=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PIDUsage Enables OS Command Injection","id":"CVE-2017-1000220","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Opencast has Incorrect Permission Assignment","id":"CVE-2017-1000221"},"packages":[{"ecosystem":"npm","fixed":["1.1.5"],"introduced":["0"],"last_affected":[],"package":"pidusage","purl":null,"source":"GHSA-h2p3-h48h-9jj7"},{"ecosystem":"npm","fixed":["1.1.5"],"introduced":["0"],"last_affected":[],"package":"pidusage","purl":"pkg:npm/pidusage","source":"GHSA-h2p3-h48h-9jj7"}],"prev":{"headline":"Command Execution in windows-cpu","id":"CVE-2017-1000219"},"products":["n/a"],"published":"2017-11-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via the pidusage library, requiring developers to upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2017-1000220/"}