# CVE-2017-1000220: PIDUsage Enables OS Command Injection

> Attackers can execute arbitrary commands via the pidusage library, requiring developers to upgrade to a patched version.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h2p3-h48h-9jj7

## What is CVE-2017-1000220?

CVE-2017-1000220 is a critical command injection vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2017-1000220?

2 open source packages ship an affected version, including pidusage. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pidusage` | npm | All versions | 1.1.5 |
| `pidusage` | npm | All versions | 1.1.5 |

Products: Pidusage Project Pidusage.

## How do I fix CVE-2017-1000220?

Upgrade pidusage to 1.1.5 or later.

## Is CVE-2017-1000220 being exploited?

There is no known exploitation of CVE-2017-1000220 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000220 and fix it if it is affected.

What it is: CVE-2017-1000220 is a critical command injection vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000220 in the wild and no public exploit code.

Affected packages and fixed versions:
- pidusage (npm): affected all versions; fixed in 1.1.5
- pidusage (npm): affected all versions; fixed in 1.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000220/ (Markdown: https://insights.sbomify.com/CVE-2017-1000220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000220
- OSV: https://osv.dev/vulnerability/CVE-2017-1000220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000220/
Summaries are generated and may contain mistakes; the official description above is the record.
