# CVE-2017-1000243: Missing permission check in Jenkins Favorite Plugin

> Attackers can modify other users' favorite settings due to missing permission checks in the Jenkins Favorite Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-268v-2qq7-84pf

## What is CVE-2017-1000243?

CVE-2017-1000243 is a medium-severity missing authorization vulnerability in n/a, published on 1 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Favorite Plugin 2.1.4 and older does not perform permission checks when changing favorite status, allowing any user to set any other user's favorites

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2017-1000243?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:favorite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:favorite` | Maven | All versions | 2.3.0 |
| `org.jvnet.hudson.plugins:favorite` | Maven | All versions | 2.3.0 |

Products: Jenkins Favorite Plugin.

## How do I fix CVE-2017-1000243?

Upgrade org.jvnet.hudson.plugins:favorite to 2.3.0 or later.

## Is CVE-2017-1000243 being exploited?

There is no known exploitation of CVE-2017-1000243 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000243 and fix it if it is affected.

What it is: CVE-2017-1000243 is a medium-severity missing authorization vulnerability in n/a, published on 1 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000243 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:favorite (Maven): affected all versions; fixed in 2.3.0
- org.jvnet.hudson.plugins:favorite (Maven): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000243/ (Markdown: https://insights.sbomify.com/CVE-2017-1000243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000243
- OSV: https://osv.dev/vulnerability/CVE-2017-1000243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000243/
Summaries are generated and may contain mistakes; the official description above is the record.
